Lost AJAX controls, now permissions issue after reloading

I created a web application using 2.0 and AJAX 1.0 a couple months ago.  All was running fine and a published copy is being reviewed by users on a testserver.  However, I just opened the project in VS 2005 and the AJAX tools were no longer in the toolbox.  I reinstalled however I do not see all of the controls in the Toolbox.  When I build the application I get two errors for each control.  One indicates that the control is "not an known element.  This can occur if there is a compilation error in the Web site."   The second is a compiler error:  "Request for the permission of type 'System.WEb.AspNetHostingPermission, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed. 

I get this pair of errors for each AJAX contol on the form. 

I can see the PublicKeyToken in the config file: 

               <add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

 

I think I am missing something in the reinstallation of AJAX Toolkit

Anyone have an idea where to go from here? 

 

———————————

Update

I found that a .dll was missing and that cleared the first error but still get the permissions error referenced above.  The .dll was the following:

C:\Program Files\Microsoft ASP.NET\ASP.NET 2.0 AJAX Extensions\AjaxControlsToolkit\Binaries\AjaxControlToolkit.dll 

 

 

 

Read More

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s